B.A.T.M.A.N

B.A.T.M.A.N. is an alias for "Better Approach To Mobile Adhoc Networking".

  • Batman-adv is a mesh protocol for a layer 2 network
  • batmand is a userspace daemon that operates on layer 3

But please see the Documentation on the Project Homepage.

OpenWrt currently uses BATMAN 2012.3 but read about difference in syntax between BATMAN 2012.x and BATMAN 2013.x

Package: kmod-batman-adv
Version: 3.3.8+2012.3.0-3
Depends: kernel (= 3.3.8-1-d6597ebf6203328d3519ea3c3371a493), kmod-lib-crc16, libc
Size: 81534
Description: B.A.T.M.A.N. advanced is a kernel module which allows to build layer 2 mesh networks. 
This package contains the version 2012.3.0 of the kernel module plus its user space configuration & 
managerment tool batctl.

Package: batmand
Version: r1439-2
Depends: libpthread, kmod-tun
Size: 37645
Description: B.A.T.M.A.N. layer 3 routing daemon

Installing and configuration of B.A.T.M.A.N advanced

Installing

opkg update
opkg install kmod-batman-adv

Configuration

Current version (OpenWRT 12.09.1, batman-adv 2013.4.0 (compatibility version 14))

/etc/config/wireless:

config wifi-iface
        option device   radio0
        option ifname   mesh0
        option network  mesh
        option mode     adhoc
        option ssid     mesh
        option bssid    '02:CA:FE:CA:CA:40'
        option mcast_rate 18000
        option encryption none

/etc/config/network:

config interface 'mesh'
        option mtu      1532
        option proto    batadv
        option mesh     bat0

config interface 'bat'
        option ifname 'bat0'
        option proto 'static'
        option mtu '1500'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'

Older versions

uci set network.bat0=interface
uci set network.bat0.ifname=bat0
uci set network.bat0.proto=static
uci set network.bat0.mtu=1500
uci set wireless.radio0.disabled=0
uci set network.bat0.ipaddr=10.1.1.1 # change ip address so that each node has different one
uci set network.bat0.netmask=255.255.255.0
uci commit
/etc/init.d/network restart
wifi

Aditional Resources

Back to top

doc/howto/mesh.batman.txt · Last modified: 2014/07/07 22:08 by theoradicus