User Tools

Site Tools


doc:howto:mwan3
This wiki is read only and for archival purposes only. >>>>>>>>>> Please use the new OpenWrt wiki at https://openwrt.org/ <<<<<<<<<<

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
doc:howto:mwan3 [2017/02/20 07:41]
wifly
doc:howto:mwan3 [2017/07/25 11:17] (current)
cmalcolm Added 'ip route show' command in section 'Verify the routing table'.
Line 180: Line 180:
  
 Create additional WAN interfaces (e.g. wan3, ...) as desired if more than two WAN connections will be used. More information on howto create interfaces can be found at https://​wiki.openwrt.org/​doc/​uci/​network. Create additional WAN interfaces (e.g. wan3, ...) as desired if more than two WAN connections will be used. More information on howto create interfaces can be found at https://​wiki.openwrt.org/​doc/​uci/​network.
 +If you are using pppoe for multiple ADSL lines from the same company, you may need to use option macaddr to give each interface a unique MAC.  The symptom of this problem is that the ISP will drop the connection on one line when another connects with the same (default) MAC.
  
 ==== The routable loopback (self) ==== ==== The routable loopback (self) ====
Line 241: Line 242:
  
 <​code>​ <​code>​
 +root@OpenWrt:​~#​ ip route show
 default via 10.0.3.2 dev eth1  proto static ​ src 10.0.3.15 ​ metric 10  default via 10.0.3.2 dev eth1  proto static ​ src 10.0.3.15 ​ metric 10 
 default via 10.0.4.2 dev eth2  proto static ​ src 10.0.4.15 ​ metric 20 default via 10.0.4.2 dev eth2  proto static ​ src 10.0.4.15 ​ metric 20
Line 967: Line 969:
       * Internal port: 1194 (this is not really needed)       * Internal port: 1194 (this is not really needed)
       * Enable NAT Loopback: enabled ​ (the default)       * Enable NAT Loopback: enabled ​ (the default)
 +
 +OpenWrt 15.05.x (Chaos Calmer) note: Unfortunately,​ the above approach doesn'​t work for UDP port-forwards to the router'​s LAN interface fail to work. TCP port-forwards are fine. This bug report talks about the issue: https://​dev.openwrt.org/​ticket/​18057. Apparently the change in the firewall3 package that broke this functionality has been reverted but the fix happened after the 15.05.x CC release.
 +
  
 == Step 3: OpenVPN client and DNS configuration == == Step 3: OpenVPN client and DNS configuration ==
doc/howto/mwan3.1487572913.txt.bz2 · Last modified: 2017/02/20 07:41 by wifly