User Tools

Site Tools


doc:recipes:dumbap

Dumb AP / Access Point Only

This document describes how to create an Access Point (AP) only. This AP allows users to connect over wireless or ethernet to the AP and an existing network. That mean this AP is not routing, provides no DHCP and no other function. This setup is needed when in your network is already a router, access control and dhcp in place and you like to use this.

From a user point of view it works like this:

  • Connect to the AP (in case of wireless WPA2 encrypted, hence a password is needed)
  • If the MAC of the users network interface matches a MAC in the list, it gets the appropriate IP and the user has network access (possibly not the best way to control network access…)

'Static DHCP' is not covered here, all we do is creating an AP that provides WPA2 encrypted wireless access and doesn't interfere.

Configuration

The changes below assume an OpenWrt default configuration, the relevant files are:

Step 1: Modify the Network

Edit /etc/config/network and change the interface section:

For switch-less devices, e.g. Alix Board, wr1043nd v2

On switchless devices, simply bridge all ethernet interfaces together, remove the existing WAN interface - if any.

config interface lan option type 'bridge' option ifname 'eth0 eth1' # Bridges lan and wan option proto 'dhcp' # Change as appropriate

For devices with switch and dedicated WAN, e.g. WNDR3700, WR1043ND v1, WR741ND v2.4

On devices with a separate WAN interface, bridge the LAN VLAN together with the WAN interface, remove the existing WAN interface - if any.

config interface lan option type 'bridge' option ifname 'eth0.1 eth1' # Bridges vlan 1 and wan option proto 'dhcp' # Change as appropriat

Switch configuration on WR1043ND (barrier breaker):

config switch_vlan option device 'switch0' option vlan '1' option ports '0 1 2 3 4 5t' # 1. add 0 in here #config switch_vlan # 2. comment out or delete the whole vlan 2 section # option device 'switch0' # option vlan '2' # option ports '0 5t'

For devices with switch only, e.g. WRT54GL

On devices where WAN and LAN are separated by switch config, reconfigure the LAN VLAN to cover all ports, remove the existing WAN interface and its related VLAN - if any.

config switch_vlan eth0_1 option vlan '1' option ports '0 1 2 3 4 5t' # Might vary depending on the device config interface lan option type 'bridge' option ifname 'eth0.1' option proto 'dhcp' # Change as appropriate

Step 2: Change the existing wireless network

Edit /etc/config/wireless, and don't worry about most of it, things that might need changes are commented.

config 'wifi-device' 'radio0' option type 'mac80211' option channel '11' option macaddr '12:e4:4a:b3:83:1a' option htmode 'HT20' list ht_capab 'SHORT-GI-20' list ht_capab 'SHORT-GI-40' list ht_capab 'TX-STBC' list ht_capab 'RX-STBC1' list ht_capab 'DSSS_CCK-40' config 'wifi-iface' option device 'radio0' option network 'lan' # Set to the name of the bridged interface option mode 'ap' option ssid 'ap_myaccesspoint' option encryption 'psk2' # Change as appropriate option key 'ap_password'

Step 3: Disable DHCP Server

If you still need dnsmasq running for something else (e.g. TFTP server) you can do:

uci set dhcp.lan.ignore=1
uci commit dhcp
/etc/init.d/dnsmasq restart

Step 4: Disable Firewall

/etc/init.d/firewall disable
/etc/init.d/firewall stop

Apply changes

Reloading the network config should be enough, it should automatically restart if necessary.

/etc/init.d/network reload

IPv6

If you would like your AP to receive IPv6 as a host only and not for routing you have to tell dhcp6c not to request prefix deligation. If you do not do this the AP will reject basic IPv6 addresses.

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname '@wan'
	option reqprefix no

Multicast Forwarding

Multicast forwarding is necessary for DLNA and UPnP clients to work properly. For example PS3, xbox, TVs and stereos use DLNA to detect, communicate with and stream audio/video over the network. Since multicasting is turned off (multicast snooping is turned on) by default in newer OpenWrt releases, it must be activated. This would forward any multicast packets to all ports allowing your TV to find your DLNA capable NAS with movies. In large networks, this could cause some overhead which may not be desirable.

Add this into /etc/rc.local

echo "0" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping
Replace br-lan with your actual bridge interface, sometimes also called br0.

This will forward all multicast packets to all ports on your bridge, making igmpproxy or udpxy proxies unnecessary.

doc/recipes/dumbap.txt · Last modified: 2014/05/15 22:19 by jamy015