User Tools

Site Tools


fr:toh:seagate:goflexhome

Seagate GoFlexHome

Versions supportée

Modèle Version OpenWrt compatible Notes spécifiques aux modèles
Seagate GoFlexHome 15.05.1 Le témoin d'activité réseau vert ne fonctionne pas

Récapitulatif

CPU Ram Flash Réseau USB Port Serie JTag
Marvell Kirkwood@1200MHz 128 MiB 256 MiB 1x Ethernet Gigabit 1x 2.0 Oui Oui

Matériels

Info

Architecture: ARM armv5te
Vendeur: Marvell
Bootloader: U-Boot
Système sur processeur: Marvell MV88F6281 A0 (DDR2) avec un processeur RISC ARM926EJ-S CPU (Marvell Feroceon)
Vitesse du CPU: 1200 Mhz
Taille de la mémoire Flash : 256 MiB
RAM: 128 MiB
Wifi: n/a
Ethernet: 1x port Ethernet Gigabit / Marvell "Alaska" 88E1116R
USB: 1x port USB 2.0
Port série: Oui

Agencement de la mémoire Flash

Couches d'origine
Partition (mtd#) mtd0 mtd1 mtd2 mtd3
début 0x000000 0x100000 0x500000 0x2500000
taille 0x100000 0x400000 0x2000000 0xdb00000
en MiB 1 4 32 219
nom u-boot uImage root data
système de fichier aucun ??? JFFS2 ??

Configuration spécifique

Interface

La configuration par défaut de la carte réseau est :

Nom de l'interface Description Configuration par défaut
eth0 Port Ethernet DHCP

Accélération matérielle de la cryptographie

SSH

sous Linux

Connectez l'appareil au port Ethernet. Pour éviter les mises à jour automatiques par les moteurs des serveurs de Seagate (qui peuvent désactiver l'accès ssh), utilisez un commutateur rj45 (switch) séparé ou débranchez votre routeur d'internet. Si l'accès ssh a été désactivé par le service de mise à jour automatique du serveur de Seagate, vous devez vous identifier et ré-activer le ssh.

Trouvez l'adresse IP, dans cet exemple BE et EF sont les deux derniers caractères de l'adresse MAC de la carte réseau RJ45 (imprimée sur l'étiquette collée en dessous du socle GoFlexHome)

root@host ~ # ifconfig eth0 169.254.1.0 
root@host ~ # nmap -e eth0 -sP $(printf "169.254.%d.%d" 0x**be** 0x**ef**)

Connectez vous en ssh à l'adresse IP trouvée (root / stxadmin) pour voir si cela fonctionne.

OpenWrt Chaos Calmer 15.05.1

Installer OpenWrt Chaos Calmer 15.05.1 dans la mémoire flash NAND via un cable série et un serveur TFTP

(Inspiré par la procédure d'installation anglaise du Seagate GoFlexNet)

Principe d'installation

A l'aide d'un câble série ( comme celui-ci (équipé d'une puce PL2303HX)) reliant un ordinateur au NAS Seagate GoFlex Home il est possible d'installer OpenWrt Chaos Calmer 15.05.1 dans la mémoire flash NAND située sur la carte mère du Seagate GoFlex Home.

  1. Changer le chargeur uboot de la NAND (mtd0) par celui de bodhi
  2. Changer uImage de la NAND (mtd1)
  3. Changer le système de fichier JFFS2 de la NAND (mtd2) par le système de fichier UBIFS (UBI File System)
  4. Installer OpenWrt OpenWrt Chaos Calmer 15.05.1 (mtd2)

Au terme de l'installation du système d'exploitation Linux (OpenWrt Chaos Calmer 15.05.1) sur le NAS Seagate GoFlex Home, la carte RJ45 fonctionnera en mode client DHCP.

cat /proc/mtd

dev:    size   erasesize  name
mtd0: 00100000 00020000 "u-boot"
mtd1: 00400000 00020000 "uImage"
mtd2: 02000000 00020000 "pogoplug"
mtd3: 0d800000 00020000 "root"

df -h

Filesystem                Size      Used Available Use% Mounted on
rootfs                   22.6M      3.1M     19.5M  14% /
ubi0:rootfs              22.6M      3.1M     19.5M  14% /
tmpfs                    61.3M    504.0K     60.8M   1% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

Prérequis

  • Un système fonctionnel reliant un ordinateur et le NAS Seagate GoFlex Home par câble série (exemple : Putty)
  • Un serveur TFTP (exemple : atftp sous linux)
  • Connaître l'adresse IP du serveur TFTP (l'idée étant d'installer le serveur TFTP sur l'ordinateur relié directement au NAS Seagate GoFlex Home, elle devrait correspondre à celle de l'ordinateur utilisé)
    • Sous linux :
      ifconfig
    • Sous Windows : [Touche Windows] + [Touche R] –> cmd
      ipconfig
  • Connaître l'adresse MAC de la carte réseau du NAS Seagate Goflex Home : Elle est indiquée sur l'étiquette située en dessous de l'appareil.

    Durant l'installation de OpenWrt, il faudra l'indiquer sous la forme 00:00:00:00:00:00

  • Une connexion réseau par RJ45 fonctionnelle. A ce sujet l'ordinateur et le NAS Seagate Goflex Home peuvent être connectés :
    • soit directement à un routeur DHCP (il faudra connaitre l'adressage IP v4 (exemple 192.168.x.x) pour attribuer une adresse IP v4 au NAS Seagate GoFlex Home durant l'installation)
    • soit directement entre eux : il faudra définir une adresse IP v4 statique sur l'ordinateur (exemple 192.168.1.2) et une adresse IP v4 statique sur le NAS Seagate GoFlex Home (exemple :192.168.1.1)
  • Les fichiers :

Installation

  1. Exécutez putty (ou autre Hyper Terminal) et allumez le NAS Seagate GoFlex Home
  2. Appuyez sur une touche pour entrer dans uboot
  3. Indiquez l'adresse IP v4 à utiliser durant l'installation pour le NAS Seagate GoFlex Home, l'adresse IP v4 du serveur TFTP ainsi que l'adresse MAC de la carte réseau du NAS Seagate GoFlex Home :
    setenv ipaddr '192.168.0.221'
    setenv serverip '192.168.0.1'
    setenv ethaddr '00:00:00:00:00:00'
Installation du fichier uboot.2016.05-tld-1.goflexhome.mtd0.kwb
  1. Téléchargez le fichier uboot.2016.05-tld-1.goflexhome.mtd0.kwb dans la RAM en partant de l'adresse 0x6400000 :
    tftp 0x6400000 uboot.2016.05-tld-1.goflexhome.mtd0.kwb
    Réponse : Bytes transferred = 524288 (80000 hex) ← ce chiffre est nécessaire pour écrire dans la mémoire flash NAND
  2. Formatez la mémoire flash NAND de taille 0x100000 depuis le point de départ 0x0 (correspond à la partition mtd0 )
    nand erase 0x0 0x100000
  3. Écrivez le fichier (de taille 0x80000) situé en RAM 0x6400000 dans la mémoire flash NAND en partant de l'adresse 0x0
    nand write.e 0x6400000 0x0 0x80000
Installation du fichier openwrt-15.05.1-kirkwood-goflexhome-uImage
  1. Téléchargez le fichier openwrt-15.05.1-kirkwood-goflexhome-uImage dans la RAM en partant de l'adresse 0x6400000 :
    tftp 0x6400000 openwrt-15.05.1-kirkwood-goflexhome-uImage
    Réponse : Bytes transferred = 1740617 (1a8f49 hex) ← ce chiffre est nécessaire pour écrire dans la mémoire flash NAND
  2. Formatez la mémoire flash NAND de taille 0x400000 depuis le point de départ 0x100000 (correspond à la partition mtd1)
    nand erase 0x100000 0x400000
  3. Écrivez le fichier (de taille 1a8f49) situé en RAM 0x6400000 dans la mémoire flash NAND en partant de l'adresse 0x100000
    nand write.e 0x6400000 0x100000 1a8f49
Installation du fichier openwrt-15.05.1-kirkwood-goflexhome-rootfs.ubifs
  1. Préparation de la partition rootfs (correspond à la partition mtd2) :
    1. Formatez la mémoire flash NAND de taille 0x2000000 depuis le point de départ 0x500000 (correspond à la partition mtd2)
      nand erase.part rootfs
      Réponse :
      NAND erase.part: device 0 offset 0x500000, size 0x2000000
      Erasing at 0x24e0000 -- 100% complete.
      OK
    2. Créez la partition rootfs
      ubi part rootfs
      Réponse :
      ubi0: attaching mtd1
      ubi0: scanning is finished
      ubi0: empty MTD device detected
      ubi0: attached mtd1 (name "mtd=2", size 32 MiB)
      ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 129024 bytes
      ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 512
      ubi0: VID header offset: 512 (aligned 512), data offset: 2048
      ubi0: good PEBs: 256, bad PEBs: 0, corrupted PEBs: 0
      ubi0: user volume: 0, internal volumes: 1, max. volumes count: 128
      ubi0: max/mean erase counter: 1/0, WL threshold: 4096, image sequence number: 0 
      ubi0: available PEBs: 212, total reserved PEBs: 44, PEBs reserved for bad PEB h0
    3. Formatez la partition rootfs en système de fichiers UBIFS :
      ubi create rootfs
      Réponse :
      No size specified -> Using max size (27353088)
      Creating dynamic volume rootfs of size 27353088
  2. Téléchargez le fichier openwrt-15.05.1-kirkwood-goflexhome-rootfs.ubifs dans la RAM en partant de l'adresse 0x6400000 :
    tftp 0x6400000 openwrt-15.05.1-kirkwood-goflexhome-rootfs.ubifs
    Réponse : Bytes transferred = 4644864 (46e000 hex) ← ce chiffre est nécessaire pour écrire dans la mémoire flash NAND
  3. Écrivez le fichier (de taille 46e000) situé en RAM 0x6400000 dans la mémoire flash NAND en partant de l'adresse 0x500000
    ubi write 0x6400000 rootfs 46e000
    Réponse :
    4644864 bytes written to volume rootfs
  4. Redémarrez le NAS Seagate Goflex Home (ne fermez pas putty et passez au paramétrage de uboot v. 2016.05-tld-1 ) :
    reset
Paramétrage de uboot v. 2016.05-tld-1
  1. Toujours depuis putty (ou autre Hyper Terminal), appuyez sur une touche pour entrer dans uboot
  2. Renseignez l'adresse MAC de la carte réseau du NAS Seagate GoFlex Home (sinon la prise ethernet (RJ45) ne fonctionnera pas) et renseignez les autres variables d'environnement de uboot :
    1. setenv baudrate '115200'
    2. setenv bootcmd '${x_bootcmd_kernel}; setenv bootargs ${x_bootargs} ${x_bootargs_root}; ${x_bootcmd_usb}; bootm 0x6400000;'
    3. setenv bootdelay '3'
    4. setenv ethact 'egiga0'
    5. setenv ethaddr 'Adresse MAC de la carte réseau du NAS Seagate GoFlex Home au format 00:00:00:00:00:00'
    6. setenv ipaddr '192.168.1.1'
    7. setenv serverip '192.168.1.2'
    8. setenv stderr 'serial'
    9. setenv stdin 'serial'
    10. setenv stdout 'serial'
    11. setenv x_bootargs 'console=ttyS0,115200 mtdparts=orion_nand:1M(u-boot),4M@1M(kernel),32M@5M(rootfs) rw,219M@37M(data)'
    12. setenv x_bootargs_root 'ubi.mtd=2 rootfstype=ubifs'
    13. setenv x_bootcmd_kernel 'nand read 0x6400000 0x100000 0x400000'
    14. setenv x_bootcmd_usb 'usb start'
    15. setenv machid c11
    16. set arcNumber '3338'
  3. Vérifier la saisie :
    printenv
  4. Enregistrez les modifications apportées :
    saveenv
  5. redémarrez :
    reset
Premier démarrage
  1. Vous devriez devoir apparaître :
    U-Boot 2016.05-tld-1 (Jun 12 2016 - 13:30:55 -0700)
    Seagate GoFlex Home
    
    SoC:   Kirkwood 88F6281_A1
    DRAM:  128 MiB
    WARNING: Caches not enabled
    NAND:  256 MiB
    In:    serial
    Out:   serial
    Err:   serial
    Net:   egiga0
    88E1116 Initialized on egiga0
    Hit any key to stop autoboot:  3 ... 2 ... 1 ... 0 
    
    NAND read: device 0 offset 0x100000, size 0x400000
     4194304 bytes read: OK
    starting USB...
    USB0:   USB EHCI 1.00
    scanning bus 0 for devices... 1 USB Device(s) found
           scanning usb for storage devices... 0 Storage Device(s) found
    ## Booting kernel from Legacy Image at 06400000 ...
       Image Name:   ARM OpenWrt Linux-3.18.20
       Created:      2015-09-11  16:53:21 UTC
       Image Type:   ARM Linux Kernel Image (uncompressed)
       Data Size:    1590917 Bytes = 1.5 MiB
       Load Address: 00008000
       Entry Point:  00008000
       Verifying Checksum ... OK
       Loading Kernel Image ... OK
    Using machid 0xc11 from environment
    
    Starting kernel ...
    
    [    0.000000] Booting Linux on physical CPU 0x0
    [    0.000000] Linux version 3.18.20 (buildbot@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46450) ) #1 Fri Sep 4 16:57:13 CEST 2015
    [    0.000000] CPU: Feroceon 88FR131 [56251311] revision 1 (ARMv5TE), cr=0005397f
    [    0.000000] CPU: VIVT data cache, VIVT instruction cache
    [    0.000000] Machine model: Seagate GoFlex Home
    [    0.000000] Memory policy: Data cache writeback
    [    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
    [    0.000000] Kernel command line: console=ttyS0,115200 mtdpart=orion_nand:1M(u-boot),4M@1M(kernel),32M@5M(rootfs) rw,219M@37M(data) ubi.mtd=2 rootfstype=ubifs
    [    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
    [    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
    [    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
    [    0.000000] Memory: 125308K/131072K available (3502K kernel code, 152K rwdata, 540K rodata, 140K init, 191K bss, 5764K reserved)
    [    0.000000] Virtual kernel memory layout:
    [    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    [    0.000000]     fixmap  : 0xffc00000 - 0xffe00000   (2048 kB)
    [    0.000000]     vmalloc : 0xc8800000 - 0xff000000   ( 872 MB)
    [    0.000000]     lowmem  : 0xc0000000 - 0xc8000000   ( 128 MB)
    [    0.000000]     modules : 0xbf000000 - 0xc0000000   (  16 MB)
    [    0.000000]       .text : 0xc0008000 - 0xc03fad4c   (4044 kB)
    [    0.000000]       .init : 0xc03fb000 - 0xc041e000   ( 140 kB)
    [    0.000000]       .data : 0xc041e000 - 0xc04440e4   ( 153 kB)
    [    0.000000]        .bss : 0xc04440e4 - 0xc0473f64   ( 192 kB)
    [    0.000000] NR_IRQS:16 nr_irqs:16 16
    [    0.000016] sched_clock: 32 bits at 200MHz, resolution 5ns, wraps every 21474836475ns
    [    0.000153] Calibrating delay loop... 1191.11 BogoMIPS (lpj=5955584)
    [    0.090097] pid_max: default: 32768 minimum: 301
    [    0.090243] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.090262] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.090753] CPU: Testing write buffer coherency: ok
    [    0.091066] Setting up static identity map for 0x108c8 - 0x10904
    [    0.091308] mvebu-soc-id: MVEBU SoC ID=0x6281, Rev=0x3
    [    0.092854] pinctrl core: initialized pinctrl subsystem
    [    0.093242] regulator-dummy: no parameters
    [    0.096824] NET: Registered protocol family 16
    [    0.097209] DMA: preallocated 256 KiB pool for atomic coherent allocations
    [    0.097928] cpuidle: using governor ladder
    [    0.098261] Feroceon L2: Enabling L2
    [    0.098306] Feroceon L2: Cache support initialised.
    [    0.098590] [Firmware Info]: /ocp@f1000000/ethernet-controller@72000/ethernet0-port@0: local-mac-address is not set
    [    0.105949] platform regulators:regulator@1: Driver reg-fixed-voltage requests probe deferral
    [    0.106346] SCSI subsystem initialized
    [    0.106668] usbcore: registered new interface driver usbfs
    [    0.106745] usbcore: registered new interface driver hub
    [    0.106810] usbcore: registered new device driver usb
    [    0.107633] Switched to clocksource orion_clocksource
    [    0.108527] NET: Registered protocol family 2
    [    0.109234] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.109258] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.109277] TCP: Hash tables configured (established 1024 bind 1024)
    [    0.109333] TCP: reno registered
    [    0.109346] UDP hash table entries: 256 (order: 0, 4096 bytes)
    [    0.109366] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
    [    0.109529] NET: Registered protocol family 1
    [    0.110319] futex hash table entries: 256 (order: -1, 3072 bytes)
    [    0.111178] squashfs: version 4.0 (2009/01/31) Phillip Lougher
    [    0.111190] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
    [    0.111423] msgmni has been set to 244
    [    0.112190] io scheduler noop registered
    [    0.112201] io scheduler deadline registered (default)
    [    0.113283] kirkwood-pinctrl f1010000.pin-controller: registered pinctrl driver
    [    0.113828] irq: Cannot allocate irq_descs @ IRQ33, assuming pre-allocated
    [    0.114141] irq: Cannot allocate irq_descs @ IRQ65, assuming pre-allocated
    [    0.146233] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
    [    0.149236] console [ttyS0] disabled
    [    0.149306] f1012000.serial: ttyS0 at MMIO 0xf1012000 (irq = 26, base_baud = 12500000) is a 16550A
    [    0.545658] console [ttyS0] enabled
    [    0.550471] nand: device found, Manufacturer ID: 0x2c, Chip ID: 0xda
    [    0.556851] nand: Micron MT29F2G08AAD
    [    0.560549] nand: 256MiB, SLC, page size: 2048, OOB size: 64
    [    0.566246] Scanning device for bad blocks
    [    0.787795] 4 ofpart partitions found on MTD device orion_nand
    [    0.793651] Creating 4 MTD partitions on "orion_nand":
    [    0.798824] 0x000000000000-0x000000100000 : "u-boot"
    [    0.804555] 0x000000100000-0x000000500000 : "uImage"
    [    0.810249] 0x000000500000-0x000002500000 : "pogoplug"
    [    0.816142] 0x000002500000-0x00000fd00000 : "root"
    [    0.822454] libphy: orion_mdio_bus: probed
    [    0.877398] mv643xx_eth: MV-643xx 10/100/1000 ethernet driver version 1.4
    [    0.885600] mv643xx_eth_port mv643xx_eth_port.0 eth0: port 0 with MAC address 00:10:75:29:88:02
    [    0.894421] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    [    0.900994] ehci-pci: EHCI PCI platform driver
    [    0.905520] ehci-platform: EHCI generic platform driver
    [    0.910902] ehci-orion: EHCI orion driver
    [    0.915075] orion-ehci f1050000.ehci: EHCI Host Controller
    [    0.920639] orion-ehci f1050000.ehci: new USB bus registered, assigned bus number 1
    [    0.928472] orion-ehci f1050000.ehci: irq 29, io mem 0xf1050000
    [    0.947654] orion-ehci f1050000.ehci: USB 2.0 started, EHCI 1.00
    [    0.954314] hub 1-0:1.0: USB hub found
    [    0.958143] hub 1-0:1.0: 1 port detected
    [    0.962653] usbcore: registered new interface driver usb-storage
    [    0.969744] TCP: cubic registered
    [    0.973076] NET: Registered protocol family 17
    [    0.977606] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
    [    0.990320] Bridge firewalling registered
    [    0.994450] 8021q: 802.1Q VLAN Support v1.8
    [    0.999887] USB Power: 5000 mV 
    [    1.003278] UBI: attaching mtd2 to ubi0
    [    1.065920] UBI: scanning is finished
    [    1.080919] UBI: attached mtd2 (name "pogoplug", size 32 MiB) to ubi0
    [    1.087394] UBI: PEB size: 131072 bytes (128 KiB), LEB size: 129024 bytes
    [    1.094239] UBI: min./max. I/O unit sizes: 2048/2048, sub-page size 512
    [    1.100897] UBI: VID header offset: 512 (aligned 512), data offset: 2048
    [    1.107623] UBI: good PEBs: 256, bad PEBs: 0, corrupted PEBs: 0
    [    1.113579] UBI: user volume: 1, internal volumes: 1, max. volumes count: 128
    [    1.120760] UBI: max/mean erase counter: 2/1, WL threshold: 4096, image sequence number: 0
    [    1.129069] UBI: available PEBs: 0, total reserved PEBs: 256, PEBs reserved for bad PEB handling: 40
    [    1.138415] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
    [    1.145768] UBI: background thread "ubi_bgt0d" started, PID 774
    [    1.179442] UBIFS: background thread "ubifs_bgt0_0" started, PID 778
    [    1.212469] UBIFS: recovery needed
    [    1.351009] UBIFS: recovery completed
    [    1.354774] UBIFS: mounted UBI device 0, volume 0, name "rootfs"
    [    1.360834] UBIFS: LEB size: 129024 bytes (126 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
    [    1.370025] UBIFS: FS size: 25933824 bytes (24 MiB, 201 LEBs), journal size 9033728 bytes (8 MiB, 71 LEBs)
    [    1.379734] UBIFS: reserved for root: 0 bytes (0 KiB)
    [    1.384811] UBIFS: media format: w4/r0 (latest is w4/r0), UUID 10F27B62-EB1A-4F42-AB31-1C3972EFF03F, small LPT model
    [    1.396133] VFS: Mounted root (ubifs filesystem) on device 0:10.
    [    1.402603] Freeing unused kernel memory: 140K (c03fb000 - c041e000)
    [    1.544204] init: Console is alive
    [    1.672887] sata_mv f1080000.sata: slots 32 ports 2
    [    1.680398] scsi host0: sata_mv
    [    1.684183] scsi host1: sata_mv
    [    1.687553] ata1: SATA max UDMA/133 irq 32
    [    1.691695] ata2: SATA max UDMA/133 irq 32
    [    2.037654] ata1: SATA link down (SStatus 0 SControl F300)
    [    2.387649] ata2: SATA link down (SStatus 0 SControl F300)
    [    2.549347] init: - preinit -
    [    2.624619] random: procd urandom read with 4 bits of entropy available
    Press the [f] key and hit [enter] to enter failsafe mode
    Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
    [    4.715498] mount_root: mounting /dev/root
    [    4.727047] procd: - early -
    [    5.793428] procd: - ubus -
    [    6.800093] procd: - init -
    Please press Enter to activate this console.
    [    8.905730] NET: Registered protocol family 10
    [    8.928836] ip6_tables: (C) 2000-2006 Netfilter Core Team
    [    8.945977] ip_tables: (C) 2000-2006 Netfilter Core Team
    [    8.980270] nf_conntrack version 0.5.0 (1960 buckets, 7840 max)
    [    9.020254] rtc-mv f1010300.rtc: rtc core: registered f1010300.rtc as rtc0
    [    9.058769] xt_time: kernel timezone is -0000
    [    9.082084] PPP generic driver version 2.4.2
    [    9.096343] NET: Registered protocol family 24
    [   11.638780] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 1000 Mb/s, full duplex, flow control disabled
    [   11.648700] mv643xx_eth_port mv643xx_eth_port.0 eth0: link down
    [   11.655826] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [   15.224525] mv643xx_eth_port mv643xx_eth_port.0 eth0: link up, 1000 Mb/s, full duplex, flow control disabled
    [   15.234452] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
  2. Appuyez sur la touche [Entrée] de votre clavier :)
  3. A l'aide du câble RJ45, connectez le NAS Seagate GoFlex Home à un routeur ayant accès à internet si vous avez utilisé la méthode IP v4 statique
  4. Un contrôle rapide que le NAS Seagate GoFlex Home à bien une adresse IP :
    1. Configuration de la carte réseau par défaut :
      cat /etc/config/network
      config interface 'loopback'
      	option ifname 'lo'
      	option proto 'static'
      	option ipaddr '127.0.0.1'
      	option netmask '255.0.0.0'
      
      config globals 'globals'
      	option ula_prefix 'fd37:807e:bb30::/48'
      
      config interface 'lan'
      	option ifname 'eth0'
      	option proto 'dhcp'
      
      config interface 'lan6'
      	option ifname '@lan'
      	option proto 'dhcpv6'
      	option reqprefix 'no'
    2. pour connaître l'adresse IP attribué par le routeur ayant accès à internet :
      ifconfig | grep inet
                inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
                inet6 addr: **********/** Scope:Link
                inet addr:127.0.0.1  Mask:255.0.0.0
                inet6 addr: ::1/128 Scope:Host
      Dans cet exemple, le NAS Seagate GoFlex Home est accessible à l'adresse IP 192.168.0.2
  5. Enfin, avant de quitter Putty, il faut attribuer un mot de passe à l'utilisateur root pour désactiver telnet, activer le protocole réseau SSH (dropbear) et administrer en HTTP (luci) :
    passwd
  6. Rendez vous à l'adresse IP du NAS Seagate Goflex Home : http://192.168.0.2 (le mot de passe est celui du compte root)
  7. Si vous souhaitez vous connecter en SSH, utilisez Putty ou bien ssh root@192.168.0.2

Dépannage post installation

OpenWrt fonctionne, j'ai une adresse IPV6 mais je n'ai pas d'adresse IPv4

Dans ce cas là il faut effacer la partition mtd3 depuis uboot :

  1. Formatez la mémoire flash NAND de taille 0xdb00000 depuis le point de départ 0x2500000 (correspond à la partition mtd3)
    nand erase 0x2500000 0xdb00000
  2. Recommencez la procédure d'installation.
Lorsque je sélectionne Network->Interface dans luci, luci renvoi une erreur et plante

(après avoir désactivé l'ip v6 dans /etc/config/network car je voulais une adresse ip v4 client dhcp)

Dans ce cas là il faut effacer la partition mtd3 depuis uboot :

  1. Formatez la mémoire flash NAND de taille 0xdb00000 depuis le point de départ 0x2500000 (correspond à la partition mtd3)
    nand erase 0x2500000 0xdb00000
  2. Recommencez la procédure d'installation.
fr/toh/seagate/goflexhome.txt · Last modified: 2016/09/23 15:14 by wild.dagger