Huawei EchoLife HG553

The HG553 is an adsl wifi router mainly distributed by Vodafone to their customers.

Supported Versions

Version/Model Launch Date S/N OpenWrt Version Supported Model Specific Notes
v1 09/2009 301880809123343 Attitude Adjustment (12.09) no DSL, no VoIP, LEDs need manual config
"Vodafone Home Gateway" (Spain) ? 303710905017230, 303710906046600 Attitude Adjustment (12.09) boots to RED :-o power light, YET works great (LAN/Wifi DHCP), no DSL, no VoIP, LEDs need manual config
"Vodafone Home Gateway" (Italy) ? 312988k14012xxx, 303688k… Attitude Adjustment (12.09) RED power light, works great, no DSL, no VoIP, LEDs need manual config. Until r39402 if USB is 1.1 only, then: unplug USB peripheral ,'poweroff',switch off, switch on, wait for reboot and retry plugging USB.

NOTE: For anything not included in model specific notes, or where a short comment couldn't be included, see the notes.

Hardware Highlights

SoC CPU speed Ram Flash Network USB Serial JTag Programmable switch
BCM6358 300 MHz 64MiB 16MiB 4x1 (100Mb/s) 2 x USB2.0 YES YES YES(BCM5325)

Installation

Flash Layout

Please read flash.layout for some insights.

OEM easy installation

  • Turn on the system while holding the reset for 30 sec.
  • connect via LAN with a manual setup of your workstation of 192.168.1.2 etc. (no DHCP, no LAN LED on the box)
  • Upload .bin file to router
  • Wait for it to reboot (you'll see a red power LED)
  • Telnet to 192.168.1.1 and set a root password, or browse to http://192.168.1.1 and set the password there…

OEM installation using the TFTP method

  • Connect the serial TTL cable to send commands to CFE for loading the firmware via tftp.
  • Start a TFTP server in your PC. Copy the openwrt-HW553-squashfs-cfe.bin firmware to the server.
  • Set the IP at your pc to 192.168.1.35 (or any compatible), and connect the ethernet cable to the router.

This is a session of flashing via TFTP:

CFE> f 192.168.1.35:openwrt-HW553-squashfs-cfe.bin Loading 192.168.1.35:openwrt-HW553-squashfs-cfe.bin ... Finished loading 2883588 bytes Flashing root file system and kernel at 0xbe020000: ~~~~~~~Flag: 3 baseAddr 0xbe000000 kernelAddr 0xbe020100 rootfsAddr 0xbe020100 tagFs 0x80800000 . . . . . . . . . . . . . . . . . . . . . . . Backup flag . ~~~~~~~Flag: 1 . *** Image flash done *** ! Resetting board...

Upgrading OpenWrt

generic.sysupgrade

If you have already installed OpenWrt and like to reflash for e.g. upgrading to a new OpenWrt version you can upgrade using the mtd command line tool. It is important that you put the firmware image into the ramdisk (/tmp) before you start flashing.

LuCI Web Upgrade Process

Terminal Upgrade Process

  • Login as root via SSH on 192.168.1.1
  • Use the following commands to upgrade.

cd /tmp/
wget http://downloads.openwrt.org/snapshots/trunk/brcm63xx/openwrt-HW553-squashfs-cfe.bin
sysupgrade /tmp/openwrt-HW553-squashfs-cfe.bin

  • If sysupgrade does not support this router, use the following commands.

cd /tmp/
wget http://downloads.openwrt.org/snapshots/trunk/brcm63xx/openwrt-HW553-squashfs-cfe.bin
mtd write /tmp/openwrt-HW553-squashfs-cfe.bin linux && reboot

Basic configuration

Basic configuration After flashing, proceed with this.
Set up your Internet connection, configure wireless, configure USB port, etc.

Specific Configuration

Interfaces

The default network configuration is: FIXME

Interface Name Description Default configuration
br-lan LAN & WiFi 192.168.1.1/24
vlan0 (eth0.0) LAN ports (1 to 4) None
vlan1 (eth0.1) WAN port DHCP
wl0 WiFi Disabled

Openwrt doesn't come with switch-config for this type of hardware, so you have to figure out for yourself or copy these lines to /etc/config/network.

-Only use wifi when modifying vlans, ALWAYS UNPLUG pc↔HG553 lan cable.

-You can also install and use robocfg to check your BCM5325 switch settings.

This example makes Port 4, which is labeled as "4/TV" the WAN-Device.

config switch 'eth1'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'eth1'
    option vlan '1'
    option ports '0 1 2 5t'

config switch_vlan
    option device 'eth1'
    option vlan '2'
    option ports '3 5t'

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth1.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option nat '1'

config interface 'wan'
    option ifname 'eth1.2'
    option _orig_ifname 'eth1.2'
    option _orig_bridge 'false'
    option proto 'dhcp'
URLs that might be helpful:

Switch Ports (for VLANs)

Install and use robocfg to discover the real name of your lan ports, and on what ETH (0 or 1) they are.

DON'T take into consideration port values robocfg puts inside parenthesis (): they refer to another unit.

Port 5 is where BCM5325 switch is.

Failsafe mode

Turn on the device and hold the reset key for 30 sec. http://192.168.1.1generic.failsafe

Buttons

hardware.button on howto use and configure the hardware button(s).

BUTTON Event
Reset
Wifi

Hardware

Info

Architecture: MIPS
Vendor: Broadcom
Bootloader: CFE
System-On-Chip: Broadcom 6358
CPU/Speed BMIPS4350 V1.0 / 300 Mhz BMIPS Dual Core
Flash-Chip: ?
Flash size: 16 MiB
RAM: 64 MiB
Wireless: Broadcom 4318 802.11b/g
Ethernet: Broadcom BCM5325 w/ vlan support swconfig
Internet: ADSL2+
VoIP:
USB: 2x 2.0
Serial: Yes
JTAG: Yes

Photos

Model Number

Front:

Photo of front of the casing

Back:

Photo of back of the casing

Opening the case

Note: This will void your warranty!

  • To remove the cover do a/b/c

Main PCB

Photo of PCB

  CPU (1F) 
  USB header (2F)
  flash (5F)
  ethernet switch (8F) 
  ram (3F) 
  circuit for VoIP 
  Wifi antenna (6F)
  5 pins headers, soldered, serial (4F)
  10 pins for JTAG (1B) 
  buffer chip (2B).

Serial

port.serial general information about the serial port, serial port cable, etc.

How to connect to the Serial Port of this specific device: UART pinout (pin 5 near capacitor) 1 TX 2 GND 3 Vcc 4 - 5 RX

JTAG

port.jtag general information about the JTAG port, JTAG cable, etc.

How to connect to the JTAG Port of this specific device: JTag pinout 10 GND 9 TDI 8 (nTRST??) 7 (??) 6 (nSRTT??) 5 TMS 4 Vcc 3 TDO 2 GND 1 TCK

Debricking

Bootloader Mods

  1. you could read about bootloader in general

Hardware mods

  1. as a beginner, you really should inform yourself about soldering in general and then obtain some practical experience!

- an italian user reports that the antenna connector found on the pcb is not working. A workaround for substituting the built-in antenna with an external antenna is found here (requires difficult desoldering and soldering) : http://www.wifi-ita.com/forum/viewtopic.php?f=7&t=10323

Quick photosummary:

- Integration of 2,5" hard disk in the box [ ITALIAN ] LINK

- Adding a secondary antenna using the MCX connector (needs a fw supporting "diversity") http://www.ilpuntotecnicoeadsl.com/forum/index.php/topic,74646.0.html

Notes

Please Follow up Support for Huawei HG553 https://forum.openwrt.org/viewtopic.php?id=30947

You can find source code in this page of the huawei forum: http://forum.huawei.com/jive4/thread.jspa?forumID=123&threadID=324322&messageID=408081#408081

Performances with Samba36 , PureFTPd,Vsftpd and USB2.0 2.5" disks:

PC(Core2duo, SSD Disk) ←ethernet100→ hw553[Vodafone S.-Italy](Barrier Breaker r39402) ↔ usb2.0 hub(two types tested(DUB-H7; CY7C65640)↔ external 2.5" HD box ("Myson Century USB2.0 to ATAPI Bridge Controller", 2.5hd(Hitachi,4200rpm,ext4)).

Test 1 : HW553 reading a 4.3Gb mkv file, Windows8-32 writing the file

Results:

- Samba36server(default config): 2.8MB/sec, CPU idle 0%.

(Various tricks tested in smb.conf.template (sendfile, SO_RCVBUF, SO_SNDBUF, aio sizes): always same result.)

The only improvement (3MB/sec) is obtained disabling SMB2 : put a # before the "max protocol = smb2" line.

- Pure-ftpd (Filezilla Win32 Client) : 2.8MB/sec, CPU idle 0%.

- vsftpd 3.0.2 (default config, Filezilla Win32 Client) : 3 MB sec, CPU idle 0%.

(Same configs with a "Lacie Little Disk"(USB2.0 to Sata,Hitachi HD(Sata3, 500gb,5400rpm,NTFS)): Same result.)

Test 2 : HW553 reading a 4.3Gb mkv file, Linux Peppermint-32bit in VirtualBox writing the file:

Results:

- pure-ftpd (and Filezilla Linux Client) : 3,3MB/s

Test 3 HW553 (firmware Dlink-Roleo: uses AIO) reading a 4.3Gb mkv file, Windows8-32 writing the file

Results :

- samba 2.0.10 : 4MB/Sec

- samba 2.0.10 without DSL processes : 4,5MB/Sec

SMP/MTC (2nd core enabling) on BCM6358

Work in progress: http://wiki.openwrt.org/doc/hardware/soc/soc.broadcom.bcm63xx/smp

Other links

Tags

For some Help with the Tags, please have a look here: tags

Back to top

toh/huawei/hg553.txt · Last modified: 2014/03/12 16:34 (external edit)