User Tools

Site Tools


Mikrotik Routerboard RB493G

Hardware Highlights

CPU Ram Flash Network USB Serial JTag MiniPCI
Atheros AR7161 680/800 MHz 256MiB 128MiB, 1x Micro-SD-socket 9x 1000Base-T 1x 2.0 unpowered Yes (console) ??? (contacts on PCB) 3x Type IIIA/B

Pricing/Where to buy

Shop Country Routerboard 493G Encasing CA493 Last checked DE 140,- € 19,- € 2012-12-25 DE 172,- € 20,- € 2012-12-25 DE 220,- $ 26,- $ 2012-12-25


Flash Layout

Please check out the article Flash.Layout. It contains an example and a couple of explanations.

root@OpenWrt:/# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 0000b000 00001000 "routerboot"
mtd1: 00001000 00001000 "hard_config"
mtd2: 00002000 00001000 "bios"
mtd3: 00001000 00001000 "soft_config"
mtd4: 00040000 00020000 "booter"
mtd5: 003c0000 00020000 "kernel"
mtd6: 07c00000 00020000 "rootfs"
The two partitions used to install OpenWrt are kernel and rootfs. Their sizes are in bytes with hex, which translates to 3840KiB for kernel and 126976KiB for rootfs.

Netboot via BOOTP/TFTP

The bootloader is able to load an image in ELF-format via BOOTP/DHCP and TFTP into RAM and execute it.

Use another OpenWrt router as netboot server

This is the easiest way to achieve a live boot of your RB493G, but it requires that you already have an OpenWrt router with net-access available. You will need to obtain an elf-image for the RB493G, and make it available to the other router. If you have enough memory available on the other router, you can put the image on the /tmp folder there, e.g., like this:

ssh root@
wget --directory-prefix=/tmp
Now enable dnsmasq's built in tftp server, and point it to the correct locations, e.g., like this: Setting up netboot in Luci, note the full path for the filename. That's it, Save and apply, connect the Eth1/WAN port of RB493G to one of the other routers LAN ports, and continue to Setup the Routerboard.

Make sure you asigned a static lease for the MAC address of the Routerboards eth1 port, otherwise bootp wont work.

Use a Debian based server for netboot

You need a BOOTP- and a TFTP-server on your host-machine, we use dnsmasq here, since it can provide both services. Install dnsmasq with:

sudo apt-get install dnsmasq

Note that network-manager has a dependency on dnsmasq-base, which will block port 53. Hence, you may need to remove dnsmasq-base, e.g., with

sudo aptitude install dnsmasq dnsmasq-base-
you may need to reinstall dependencies that will be removed in the process. ref.

Changes in /etc/dnsmasq.conf:

  1. make sure the LAN has internet access:
  2. only listen on the interface which is directly connected to the same LAN like the WAN-port (Eth1/PoE) of the RouterBoard via a layer2 switch, e.g.
  3. set default gateway, e.g.
  4. allow a DHCP range which is within netmask of your LAN but does not conflict with other DHCP-service, e.g.
  5. allocate an IP address to the board, e.g.
    (replace the XX with the MAC address of your board!)
  6. enable dnsmasq's built-in TFTP-server
  7. set the root directory-for files available via TFTP.
  8. download initramfs-kernel-image into root-directory of the TFTP-server:
    wget --directory-prefix=/srv/tftp
  9. set filename of kernel image for tftp-server/BOOTP:

Finally restart dnsmasq

sudo /etc/init.d/dnsmasq restart

Setup the Routerboard

  1. Connect to the serial port with a null modem cable (115200, 8N1, no handshaking).
  2. Press a key shortly after powering the board.
  3. Press o to change the boot device
  4. Press 1 to boot from ethernet once.
  5. Press x to leave setup (-o-1-x is needed only once, the boot method is saved in non-volatile memory)

If everything is setup correctly it should look like:


RouterBOOT booter 2.29

RouterBoard 493G

CPU frequency: 680 MHz
  Memory size: 256 MB

Press any key within 2 seconds to enter setup..
writing settings to flash... OK
trying bootp protocol... OK
Got IP address:
resolved mac address 00:14:0B:3F:BB:C3
transfer started ............................... transfer ok, time=1.46s
setting up elf image... OK
jumping to kernel code
[    0.000000] Linux version 3.3.8 (renne@renne) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Mon Sep 17 12:57:18 CEST 2012
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR7161 rev 2
[    0.000000] Clocks: CPU:680.000MHz, DDR:340.000MHz, AHB:170.000MHz, Ref:40.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] User-defined physical RAM map:
[    0.000000]  memory: 10000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone PFN ranges:
[    0.000000]   Normal   0x00000000 -> 0x00010000
[    0.000000] Movable zone start PFN for each node
[    0.000000] Early memory PFN ranges
[    0.000000]     0: 0x00000000 -> 0x00010000


Please press Enter to activate this console. [   21.710000] device eth0 entered promiscuous mode
[   21.720000] device eth1.1 entered promiscuous mode
[   21.720000] device eth1 entered promiscuous mode
[   23.110000] eth0: link up (1000Mbps/Full duplex)
[   23.130000] br-lan: port 1(eth0) entered forwarding state
[   23.130000] br-lan: port 1(eth0) entered forwarding state
[   23.600000] eth1: link up (1000Mbps/Full duplex)
[   23.610000] br-lan: port 2(eth1.1) entered forwarding state
[   23.620000] br-lan: port 2(eth1.1) entered forwarding state
[   25.130000] br-lan: port 1(eth0) entered forwarding state
[   25.620000] br-lan: port 2(eth1.1) entered forwarding state

Press Enter and you are in the console of OpenWRT running from RAM and booted via BOOTP/TFTP.

Note that you may need to set dns servers to get net-access while running the netbooted image. Enter a working dns for you in

vi /tmp/
then restart dnsmasq to make the change effective (cross-check that you indeed have net-access afterwords):
/etc/init.d/dnsmasq restart

Permanent Installation

You need a working Netboot first, see above.

Erase the NAND Flash

If you want to install OpenWrt permanently into the NAND flash you once need to erase the NAND flash to get rid of the RouterOS stuff:

  1. connect via serial line
  2. press a key shortly after powering the RB493G up
  3. press e and type yes to format the flash from the bootloader
  4. power off the Routerboard

Install OpenWrt into Flash

  1. Start Netboot (see above).
  2. Press ENTER to get a shell prompt.
  3. Execute:


You can adjust the path-part dependend on the OpenWRT-version ('attitude_adjustment/12.09'), but make sure you use the 'ar71xx/nand/'-branch and at least version '12.09-rc2'.

Upgrading OpenWrt

Use the Permanent-Installation-Guide via BOOTP/TFTP-Netboot from above.

An installation experience

Providing tftp boot and images with an existing openwrt router

On the existing openwrt router

File /etc/config/dhcp

config dnsmasq
        option 'enable_tftp' '1'
        option 'tftp_root' '/tmp/tftpboot/'

config 'boot' 'pxe_mikrotik_rb493g'
        option 'filename' 'vmlinux'
        option 'servername' 'routersetup'
        option 'serveraddress' ''

config 'host' 'mikrotik'
        option 'name'   'mikrotik'
        option 'mac'    '<the ip address of the eth1 port on the mikrotik> You can find it from the mikrotik winbox interface'
        option 'ip'     ''

config dhcp 'lan'
        option interface 'lanmikrotik'
        option start '10'
        option limit '150'
        option leasetime '10m'


File /etc/config/network


config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.0'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config interface 'lanmikrotik'
        option ifname 'br-lan' #it is an alias interface
        option proto 'static'
        option ipaddr ''
        option netmask ''

We need to provide files. Therefore:

cd /tmp/
mkdir tftpboot
wget ''
#this image is needed for booting from the ram

ln -s openwrt-ar71xx-nand-vmlinux-initramfs.elf vmlinux
# to match the bootloader requests

  • Connect the eth1 port of the mikrotik to the lan ports of the openwrt router.
  • Unplug the power cable of the mikrotik.
  • With the proper tool press the button (o reset button) near to the eth1 interface on the mikrotik and hold it (continue reading).
  • Plug the mikrotik power cable.
  • Wait for the boot of the mikrotik (careful, if the mikrotik has a license level 0 won't be possible to boot in this way).
  • After 15-20 seconds from the boot, release the button.
  • Now connect the port "eth2" on the mikrotik to a proper device. It should show the openwrt interface, reachable on .

From the openwrt interface loaded, via telnet, we can do the following:

# wait until "Image written, you can now reboot. Remember to change the boot source to Boot"
# but we don't have to change nothing because we won't press the reset button that enables the tftp from bootloader.

Basic configuration

Basic configuration After flashing, proceed with this.
Set up your Internet connection, configure wireless, configure USB port, etc.

Specific Configuration


The default network configuration is:

Interface Name Description Default configuration
br-lan (eth0, eth1.1) LAN
eth1.2 WAN DHCP

Switch Ports (for VLANs)

The default switch configuration is:

Board Switch Port VLAN Interface
0 CPU 1
Eth5 0 1 1 eth0
Eth2 0 2 1 eth0
Eth3 0 3 1 eth0
Eth4 0 4 1 eth0
0 5 off
1 CPU 1/2
Eth9 1 1 1 eth1.1
Eth6 1 2 1 eth1.1
Eth8 1 3 1 eth1.1
Eth7 1 4 1 eth1.1
Eth1/PoE 1 5 2 eth1.2

''/etc/config/network'' every port usable as single port

config interface 'loopback'
	     option ifname 'lo'
	     option proto 'static'
	     option ipaddr ''
	     option netmask ''

config switch
	     option name 'switch0'
	     option reset '1'
	     option enable_vlan '1'

# eth5
config switch_vlan
	     option device 'switch0'
	     option vlan '1'
	     option ports '0t 1'

# eth2
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 2'

# eth3
config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 3'

# eth4
config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '0t 4'

config switch
	      option name 'switch1'
	      option reset '1'
	      option enable_vlan '1'

# eth9
config switch_vlan
	      option device 'switch1'
	      option vlan '1'
	      option ports '0t 1'

# eth6
config switch_vlan
        option device 'switch1'
        option vlan '2'
        option ports '0t 2'

# eth8
config switch_vlan
        option device 'switch1'
        option vlan '3'
        option ports '0t 3'

# eth7
config switch_vlan
        option device 'switch1'
        option vlan '4'
        option ports '0t 4'

# eth1
config switch_vlan
        option device 'switch1'
        option vlan '5'
        option ports '0t 5'

Failsafe mode


hardware.button on howto use and configure the hardware button(s).

The Routerboard 493G has one software reset button.

Reset reset


The SD-card reader is now supposed to work, but the needed patch is currently not in trunk. You will find the ticket with history here:

Hence precompiled images with working SD-card reader is not yet available from the OpenWrt server. Until that is resolved, you can find compiled kernel and rootfs here:

Provide them on a web-server, or copy them manually over to the kernel and rootfs partitions on the nand.


The USB-port of the RB493G is a shameful chapter of Mikrotik engineering.

The USB-standard demands a 5VDC-power-supply on the USB-socket, but Mikrotik tried to save a few cents for a voltage converter. So one has to buy a power-injector from Mikrotik and any 5VDC-power-supply. Pray the plug of your power-supply fits into the power-injector! Just using a powered USB-hub doesn't solve the problem, as USB-hubs only enumerate/register with the host-controller when 5VDC is supplied by the host-controller.

Reliable vendors just update their PCB-layout, but Mikrotik sells that non-standard/sub-standard PCB-layout for years, now.

The Routerboard has a OHCI-controller for USB 1.x and a EHCI-controller for USB 2.0.

See usb.essentials for configuration.



Architecture: MIPS-BE
Vendor: Mikrotik / Qualcomm Atheros
Bootloader: MikroTik RouterBoot (Rescue- and Main-Bootloader)
Default Operating System: MikroTik RouterOS v4, Level5-license
System-On-Chip: Atheros AR7161 rev 2
CPU/Speed MIPS 24Kc rev 00019374 680/800 Mhz
Flash-Chip: Samsung NAND 128MiB 3,3V 8-bit, ST Micro NAND01GW3B2CN6 or Toshiba NAND 128MiB 3,3V 8-bit
Flash size: 128 MiB NAND-Flash
Micro-SD: 1x Micro-SD-socket (probably SPI)
Wireless: optional via 3x Mini-PCI IIIA/B
Ethernet: 9x 10/100/1000Base-T(X) (2x Atheros AR8316-5-port-switch with VLAN support swconfig
Internet: n/a/xDSL/DOCSIS/3g/LTE
USB: 1x 2.0 (unpowered)
Serial: YES 1x Sub-DB9 RS-232C asynchronous
JTAG: Maybe (contatcs on PCB, not tested)
LED: Power, NAND activity, 5x user LED
Power options: 10..28 VDC Power-over-Ethernet or Power-Jack
Power consumption: ~3 Watt, up to 10 Watt for MiniPCI-cards, maximum 16 Watt
Dimensions: 160 mm x 105 mm, 189 grams


Casing: Mikrotik case CA493 with two N-pigtails and -antennas (antennas are ALFA ARS-N19CW, 2.4GHz 9dBi - pigtails and antennas not included in enclosure package)
Enclosure Mikrotik CA493 - top view with antennas

Casing: Mikrotik CA493 with serial port, Ethernet-port, LEDs and power-connector of Routerboard RB493G
Enclosure Mikrotik CA493 - frontside

Casing: Mikrotik CA493 with two N-pigtails (not included), multi-purpose hole (e.g. N-connector, Swivel-antenna, …) and ground-screw
Enclosure Mikrotik CA493 - backside

Left/Top: Casing: Mikrotik CA493 with eight Ethernet-ports of Routerboard RB493G
Enclosure Mikrotik CA493 - left side

Right: Casing: Mikrotik CA493 with venting holes
Enclosure Mikrotik CA493 - right side

Bottom: Casing: Mikrotik CA493
Enclosure Mikrotik CA493 - bottom

Casing opened:
Casing: Mikrotik CA493 with two N-pigtails (not included), Routerboard 493G and Routerboard R52nM (Wifi-card)
Enclosure Mikrotik CA493 with PCBs

Opening the case

  • To remove the cover just unscrew the 4 screws (2 left side, two right side)

Main PCB top
Mikrotik Routerboard 493GAH - frontside

  • Power socket
  • 2x LED
  • 1x 1000Base-T with proprietary POE
  • 1x Sub-D9 Serial Port (Console by default)
  • 8x 1000Base-T Port
  • 1x Reset-contacts
  • 2x Atheros AR8316 (under heatsinks)
  • 1x JTAG-contacts
  • 1x USB 2.0 (unpowered)
  • 3x MiniPCI Type IIIA/B
  • 2x RAM SAMSUNG K4H510838G-LCCC
  • 2x regulated Fan-connector 3.3V 500mA
  • 2x regulated Fan connector main voltage 500mA
  • 4x Screw holes

Main PCB bottom
Mikrotik Routerboard 493GAH - backside with microSD slot

  • Flash: ST NAND01GW382CNb
  • Flash: microSD-Socket
  • RAM: 2x SAMSUNG K4H510838G-LCCC


The Routerboard has one serial interface in form of a Sub-D9-socket. By default it provides a serial console. It can be accessed with a Null-Modem-Cable (115200, 8N1, no handshaking!).


There are seven contacts named "JTAG" between USB- and MiniPCI-Socket, but not tested.



In worst case keep "Reset"-button pressed when powering on the Routerboard to access the recovery-boot-loader via serial console. That way the Routerboard can be re-flashed with a RouterOS-image (NPK-file) using the origin MikroTik-Netinstall-software (BOOTP/TFTP).

Hardware Mods

As a beginner, you really should inform yourself about soldering in general and then even obtain some experience!



1x PCB
1x USB-2.0-dual-A-socket, e.g., these.
1x USB-2.0- A-plug, e.g., these.
1x Traco TSR 1-2450 step-down-converter 5VDC/1A (doesn't need any other components like capacitors or heatsink). As of this writing you will find the LM7805V voltage regulator at DealExtreme
1x Multifuse 60VDC/0,5A Ihold/1A Itrip

Proto-type and diagrams/layouts aren't beauties, but maybe someone with more Cadsoft-Eagle-experience can make a nice circuit-diagram and a real PCB-layout: Eagle files and datasheets ;-)

Rudimentary circuit-diagram with USB-2.0 data-port (1) and generic USB-2.0 charger port (2), both supplied by a step-down-converter via the fan-connector of the RB493G:

Rudimentary PCB-layout, not applicable:

USB-mod prototype top-view:

USB-mod prototype bottom-view:

USB-mod prototype attached:


For some Help with the Tags, please have a look here: tags

toh/mikrotik/rb493g.txt · Last modified: 2015/10/23 20:16 by tmomas