User Tools

Site Tools


toh:mikrotik:rb750gl

Mikrotik RouterBoard RB750GL

Small SOHO router with five independent Gigabit Ethernet ports and optional switch chip functionality.

Supported Versions

Hardware Highlights

Installation / Flashing howto

With a linux workstation

Here is a simple guide to flash OpenWrt on your RB750GL from your Linux workstation. For more details and alternative method, see Eric Conrad's blog Installing OpenWRT on a RouterBOARD 750GL.

Get these files (available here for the RC3 Barrier Breaker release):

openwrt-ar71xx-mikrotik-vmlinux-initramfs.elf
openwrt-ar71xx-mikrotik-vmlinux-lzma.elf
openwrt-ar71xx-mikrotik-DefaultNoWifi-rootfs.tar.gz

Rename the file openwrt-ar71xx-mikrotik-DefaultNoWifi-rootfs.tar.gz as openwrt-ar71xx-mikrotik-rootfs.tar.gz.

Set a static ip for your wired interface:

$ sudo ip a a 192.168.0.200/24 dev eth0

Start Dnsmasq (DHCP+TFTP server):

$ sudo dnsmasq --no-daemon --port=0 --dhcp-range="192.168.0.50,192.168.0.150,12h" --enable-tftp --bootp-dynamic --dhcp-boot="openwrt-ar71xx-mikrotik-vmlinux-initramfs.elf" --tftp-root="/path/to/downloaded/files"

Connect the first port of the device to your wired interface, press the RES button on the device and connect it to power. Wait until you see Dnsmasq assigning an ip to the device, then release the button.

Dnsmasq loads the boot image via tftp. Wait until your device reboots (you will see Dnsmasq assigning it an ip again).

Connect to the second ethernet port and assign an ip to your interface from the 192.168.1.0/24:

$ sudo ip a a 192.168.1.200/24 dev eth0

Set up a http server serving the directory where you have the OpenWrt image files:

$ cd /path/to/downloaded/files
$ python -m http.server 8080

Telnet in your router and install OpenWrt to nand:

:!: This step will permanently erase your RouterOS installation. Please backup your RouterOS license if needed.

$ telnet 192.168.1.1
# wget2nand http://192.168.1.200:8080
# reboot && exit

With the help of another openwrt router

See the steps for the routerboard 493g: rb493g

Basic configuration

Basic configuration After flashing, proceed with this.
Set up your Internet connection, configure wireless, configure USB port, etc.

Specific Configuration

Network interfaces

The default network configuration is:

Interface Name Description Default configuration
br-lan LAN 192.168.1.1/24
eth0.1 Ports (2 to 5) None
eth0.2 Port 1 DHCP

Switch

Default after openwrt installation

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

Every port as single port

config interface 'lan'
        option ifname 'eth0.2 eth0.3 eth0.4 eth0.5'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.1'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

#port 1/Poe
config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1'

#Ethernet 2
config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 2'

#Ethernet 3
config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 3'

#Ethernet 4
config switch_vlan
        option device 'switch0'
        option vlan '4'
        option ports '0t 4'
        
#Ethernet 5
config switch_vlan
        option device 'switch0'
        option vlan '5'
        option ports '0t 5'        

Hardware

General
Brand MikroTik
Model RB750GL
Versions
Device Type Single Board Computer
Availability Discontinued 2015
Comments - general Early versions only had 64 MB NAND
OpenWrt Support
Supported Since Revision https://dev.openwrt.org/changeset/31025
Supported Since Release 12.09
Supported Current Release 15.05
Unsupported
Hardware
Instruction set MIPS32
Sub Instruction Set MIPS32 24K/E series
Bootloader other
Target ar71xx
System-On-Chip Atheros AR7242
CPU MHz 400
Flash MB 128NAND
RAM MB 64
Network
Ethernet 100M ports -
Ethernet Gbit ports 5
Switch Atheros8327
Modem No
VLAN Yes
Comments - network ports
Wireless
WLAN 2.4GHz -
WLAN 5.0GHz -
WLAN Hardware
Detachable Antennas -
Comments - WLAN
Interfaces
USB ports -
SATA ports -
Serial No
JTAG No
Comments - USB & SATA ports
Misc
LED count 1
Button count 1
Power supply
Links
Forum Topic URL
WikiDevi URL https://wikidevi.com/wiki/MikroTik_RouterBOARD_750GL
OEM device homepage URL http://routerboard.com/RB750GL
Firmware OEM Stock URL
Firmware OpenWrt Install URL https://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/mikrotik/
Firmware OpenWrt Upgrade URL https://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/mikrotik/
Edit the underlying data View/Edit data

Photos of PCB (circa May 2014). Note that there appear to be testpoints for a serial port connection along with 3.3V power. In addition you can see the spot where USB could be, but the connector and power supply apear to de-populated. The back side was very uninteresting.

Tags

toh/mikrotik/rb750gl.txt · Last modified: 2016/02/12 03:34 by rayknight