NetComm NB6PLUS4W

ZTE ZXDSL 531B(II)

Dynalink RTA1025W

Supported Versions

Version/Model S/N Release Date OpenWrt Version Supported Model Specific Notes
Board ID RTA1025W_16 - Attitude Adjustment 'mtd fixtrx linux' is needed on first boot

Hardware

Hardware information

Instruction set: MIPS
Vendor: Broadcom
Board layout vendors : ZTE, Dynalink, NetComm
Bootloader: CFE
Board Id: RTA1025W_16
System-On-Chip: BCM6348KPBG
CPU/Speed BMIPS3300 V0.7 / 240 MHz
Flash-Chip: MX29LV320DB
Spansion S29GL032A90TFIR4
Flash size: 4 MiB
RAM Chip: Elpida EDS1216AATA
HY57V281620ETP-H
RAM size: 16 MiB
Wireless: Broadcom BCM4318
Switch: Broadcom BCM5325
Internet: ADSL2+ (Annex A and B)
USB: Yes 1 x 1.1 Device mode
Serial: Yes

cpuinfo

NetworkPro@OpenWrt:/# cat /proc/cpuinfo 
system type             : bcm63xx/RTA1025W_16 (0x6348/0x00B0)
processor               : 0
cpu model               : Broadcom BMIPS3300 V0.7
BogoMIPS                : 239.10
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 32
extra interrupt vector  : yes
hardware watchpoint     : no
ASEs implemented        :
shadow register sets    : 1
kscratch registers      : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

Installation

1. Update the CFE (bootloader) and image format by flashing a new stock firmware

Flash this firmware Dynalink RTA1025W / NetComm NB6PLUS4W In firmware 3.64y the CFE will be "Boot Loader, Version 1.0.37-6.8.5"

Or try some of these if there is any newer CFE in them Stream-TST Firmware Files Forum page (not tested by myself at time of writing)

telnet

Trying 192.168.1.1...
Connected to 192.168.1.1.
Escape character is '^]'.
                   =======================
                   Welcome to ZXDSL 531BII
                   =======================

ZTE Inc., Software Release ZXDSL 531BIIV3.1.0e_B09_BG

Login name: root
Password: rootWLaccess
> sh
BusyBox v1.00 (2005) Built-in shell (msh)
Enter 'help' for a list of built-in commands.
#

#tftp -g -f cfe-nb6plus4w-v364y_a2pb025c.bin -t i 192.168.1.20
Done removing processes
Checking Image tag.....
User request image with tag 'RTA1025W_16' flash into board ID 'RTA1025W_16'
Allocating 2382435 bytes for broadcom image.
Memory allocated
Total image size: 2382427
Checking Image tag.....
User request image with tag 'RTA1025W_16' flash into board ID 'RTA1025W_16'

[1]     Askey format verified.
Tftp image done.

Flashing CFE...

2. Flash the OpenWRT image - use any preffered method http://downloads.openwrt.org/snapshots/trunk/brcm63xx/openwrt-RTA1025W_16-jffs2-64k-cfe.bin

3. On first boot enter 'mtd fixtrx linux' command in the OpenWRT console without this - the CFE will not boot and will wait for flashing a new firmare

root@OpenWrt:/# mtd fixtrx linux
Trying to fix trx header in linux at 0x0...
Verifying we actually have an imagetag.
Checking current fixed status.
Setting root length to 0.
Recalculating CRCs.
Erasing imagetag block
New image crc32: 0x9b1ddef0, rewriting block
New header crc32: 0x9f797d3c, rewriting block
Done.
root@OpenWrt:/# 

Example config

Wi-Fi AP bridged with VLAN 15

opkg remove dnsmasq dropbear firewall iptables jshn kmod-ipt-conntrack kmod-ipt-core kmod-ipt-nat kmod-ipt-nathelper kmod-ppp kmod-pppoe kmod-pppox kmod-switch libblobmsg-json libc libgcc libip4tc libjson libxtables luci luci-app-firewall luci-i18n-english luci-lib-core luci-lib-ipkg luci-lib-lmo luci-lib-nixio luci-lib-sys luci-lib-web luci-mod-admin-core luci-mod-admin-full luci-proto-core luci-proto-ppp luci-sgi-cgi luci-theme-base luci-theme-openwrt ppp ppp-mod-pppoe uhttpd

root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    2.9M      2.3M    556.0K  81% /
/dev/root                 2.9M      2.3M    556.0K  81% /
tmpfs                     6.4M     32.0K      6.4M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
root@OpenWrt:/# opkg list-installed
base-files - 115-r33312
busybox - 1.19.4-3
hotplug2 - 1.0-beta-4
iw - 3.3-1
jshn - 2012-07-08-cca2ed6c8cdb3555fea43ff63ba1c9905dd7a164
kernel - 3.3.8-1-f7b19a853fcc6494bd48aec653b15eda
kmod-b43 - 3.3.8+2012-07-16-1
kmod-bcma - 3.3.8-1
kmod-button-hotplug - 3.3.8-3
kmod-cfg80211 - 3.3.8+2012-07-16-1
kmod-crypto-aes - 3.3.8-1
kmod-crypto-arc4 - 3.3.8-1
kmod-crypto-core - 3.3.8-1
kmod-input-core - 3.3.8-1
kmod-input-gpio-keys-polled - 3.3.8-1
kmod-input-polldev - 3.3.8-1
kmod-lib-crc-ccitt - 3.3.8-1
kmod-mac80211 - 3.3.8+2012-07-16-1
libblobmsg-json - 2012-07-08-cca2ed6c8cdb3555fea43ff63ba1c9905dd7a164
libc - 0.9.33.2-1
libgcc - 4.6-linaro-1
libiwinfo - 35
libiwinfo-lua - 35
libjson - 0.9-2
liblua - 5.1.4-8
libnl-tiny - 0.1-3
libubox - 2012-07-08-cca2ed6c8cdb3555fea43ff63ba1c9905dd7a164
libubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
libubus-lua - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
libuci - 2012-03-28.1-1
libuci-lua - 2012-03-28.1-1
lua - 5.1.4-8
mtd - 18
netifd - 2012-08-11-9411d498c46fe3f1c4d79eb8fa0b7c97dd32a990
opkg - 618-2
ubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
ubusd - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
uci - 2012-03-28.1-1
wireless-tools - 29-5
wpad-mini - 20120428-2
lsmod after a reboot:
root@OpenWrt:/# lsmod
Module                  Size  Used by    Tainted: G  
gpio_keys_polled        2064  0 
button_hotplug          2624  0 
b43                   291488  0 
bcma                   21904  1 b43
mac80211              253104  1 b43
crc_ccitt                944  0 
input_polldev           1680  1 gpio_keys_polled
cfg80211              151792  2 b43,mac80211
compat                  3376  3 b43,mac80211,cfg80211
input_core             20608  3 gpio_keys_polled,button_hotplug,input_polldev
arc4                     768  2 
aes_generic            31536  2 
crypto_algapi           9168  2 arc4,aes_generic
root@OpenWrt:/#vi /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wlan15'
        option proto 'none'
        option type 'bridge'
        option _orig_ifname 'eth1.15'
        option _orig_bridge 'true'
        option ifname 'eth1.15'
        option auto '1'
vi /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr '<themacaddress>'
        option hwmode '11g'
        option txpower '20'
        option country 'BO'
        option channel '1'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid '<thename>'
        option encryption 'psk2+ccmp'
        option key '<thepassword>'
        option network 'wlan15'

/etc/rc.local

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.


ifconfig eth1 -multicast
ifconfig eth1.15 -multicast
ifconfig wlan0 -multicast
ifconfig br-wlan15 -multicast
ifconfig wlan0 txqueuelen 0

exit 0

/etc/sysctl.conf

kernel.panic=3
net.ipv4.conf.default.arp_ignore=1
net.ipv4.conf.all.arp_ignore=1
net.ipv4.ip_forward=0
net.ipv4.icmp_echo_ignore_broadcasts=1
net.ipv4.icmp_ignore_bogus_error_responses=1
net.ipv4.tcp_ecn=0
net.ipv4.tcp_fin_timeout=30
net.ipv4.tcp_keepalive_time=120
net.ipv4.tcp_syncookies=0
net.ipv4.tcp_timestamps=1
net.ipv4.tcp_sack=1
net.ipv4.tcp_dsack=1

net.ipv4.netfilter.ip_conntrack_checksum=0
net.ipv4.netfilter.ip_conntrack_max=16384
net.ipv4.netfilter.ip_conntrack_tcp_timeout_established=3600
net.ipv4.netfilter.ip_conntrack_udp_timeout=60
net.ipv4.netfilter.ip_conntrack_udp_timeout_stream=180
net.ipv6.conf.all.forwarding=0

net.netfilter.nf_conntrack_acct=1
net.netfilter.nf_conntrack_checksum=0
net.netfilter.nf_conntrack_max=16384
net.netfilter.nf_conntrack_tcp_timeout_established=3600
net.netfilter.nf_conntrack_udp_timeout=60
net.netfilter.nf_conntrack_udp_timeout_stream=180

# disable bridge firewalling by default
net.bridge.bridge-nf-call-arptables=0
net.bridge.bridge-nf-call-ip6tables=0
net.bridge.bridge-nf-call-iptables=0

net.ipv4.igmp_max_memberships = 0
net.ipv4.igmp_max_msf = 0
net.ipv4.conf.all.force_igmp_version = 0
net.ipv4.conf.default.force_igmp_version = 0
net.ipv4.neigh.default.mcast_solicit = 0
net.ipv4.neigh.lo.mcast_solicit = 0
net.ipv4.neigh.eth0.mcast_solicit = 0
net.ipv4.neigh.eth1.mcast_solicit = 0
net.ipv4.neigh.br-wlan15.mcast_solicit = 0
net.ipv4.neigh.eth1.15.mcast_solicit = 0
net.ipv4.neigh.wlan0.mcast_solicit = 0
net.ipv4.conf.all.mc_forwarding = 0
net.ipv4.conf.default.mc_forwarding = 0
net.ipv4.conf.lo.mc_forwarding = 0
net.ipv4.conf.eth0.mc_forwarding = 0
net.ipv4.conf.eth1.mc_forwarding = 0
net.ipv4.conf.br-wlan15.mc_forwarding = 0
net.ipv4.conf.eth1.15.mc_forwarding = 0
net.ipv4.conf.wlan0.mc_forwarding = 0

This is all the useful information for this example configuration. The Ethernet frames are bridged by OpenWRT from the Wi-Fi AP to VLAN 15 on the LAN side.

Photos

Serial Console

Serial connector (white, look at the pictures)
 ___
| 1 | -> Rx
| 2 | -> Tx
| 3 | -> GND
|_4_| -> +3,3V


 ___
|USB| For orientation...
|___|

Stock Firmware GPL Source Code

Here's the source code for the very similar Siemens SL2-141-i with Board ID RTA1025BW_16. The source code is hosted at alibstechnologies because they bought the Siemens broadband company.

Forum Discussion

Tags

Back to top

toh/netcomm/nb6plus4w.txt · Last modified: 2013/08/04 13:59 by lorema