Widemac SL-R720X

This is a white-label mass-market ralink-based router produced by Bococom, selling under the Widemac SL-R720X label. The device is sometimes also referred to as XDX-RN502J, a string that appears prominently on the PCB board. Some of the devices ship with openwrt preinstalled.

Supported Versions

Version/Model Launch Date S/N OpenWrt Version Supported Model Specific Notes
SL-R7205 unknown 3GR200910847 G52MAY110924 r30809 2T2R MIMO

rebranded versions

  • 3G-52 from CD-R King
  • Aceex 22NRY
  • possibly the Asus RT-N13U

Hardware Highlights

CPU Ram Flash Network USB Serial JTag
ralink rt3052@384MHz 32MiB 4MiB 4 + 1 1 * USB2.0 Yes No

Installation

Get an image built that includes r30809 or build one yourself from trunk.

Flash Layout

Please check out the article Flash Layout. It contains an example and a couple of explanations.

On this device, flash layout is the following:

0x000000000000-0x000000030000 "u-boot"
0x000000030000-0x000000040000 "u-boot-env"
0x000000040000-0x000000050000 "factory"
0x000000050000-0x000000150000 "kernel"
0x000000150000-0x000000400000 "rootfs"

auto-created partitions at boot: mtd: partition "rootfs" set to be root filesystem mtd: partition "rootfs_data" created automatically, ofs=2E0000, len=120000

0x0000002e0000-0x000000400000 "rootfs_data"
0x000000050000-0x000000400000 "firmware"

OEM installation using the TFTP method

OpenWrt was installed with the serial port and tftp method. There is currently no known way to flash directly from the built-in firmware. So, follow generic.flashing.tftp for general setup of a tftp server and firmware to load. Use the sysupgrade image. Set your terminal to 57600 bauds, 8,N, 1. At boot, you will see the following on your serial terminal:

please choose the operation: 1: Load system code to SDRAM via TFTP. 2: Load system code then write to Flash via TFTP. 3: Boot system code via Flash (default). 4: Entr boot command line interface. 9: Load Boot Loader code then write to Flash via TFTP.

choose 2, then answer the prompts. Note that option 1 does not work with the sysupgrade image; booting will fail on finding the root partition.

After installation, copy-paste the following configuration into /etc/config/network

config interface 'loopback'
      option ifname 'lo'
      option proto 'static'
      option ipaddr '127.0.0.1'
      option netmask '255.0.0.0'

config globals 'globals'
      option ula_prefix 'fd37:bd9a:2b09::/48'

config switch 'switch0'
      option enable '1'
      option enable_vlan '1'
      option reset '1'

config switch_vlan
      option vlan '1'
      option device 'switch0'
      option ports '0 6t'

config switch_vlan
      option vlan '2'
      option device 'switch0'
      option ports '1 2 3 4 6t'

config switch_port                                         
      option port '0'
      option pvid '1'

config interface 'lan'
      option force_link '1'
      option type 'bridge'
      option proto 'static'
      option ipaddr '192.168.1.1'
      option netmask '255.255.255.0'
      option ip6assign '60'
      option _orig_ifname 'eth0.2 wlan0'
      option _orig_bridge 'true'
      option ifname 'eth0.2'
      option nat '1'

config interface 'wan'
      option proto 'dhcp'
      option _orig_ifname 'eth0.1'
      option _orig_bridge 'false'
      option ifname 'eth0.1'
      option broadcast '1'

Reboot, and the network ports should be operational.

WARNING: The current OpenWRT image does not contain a valid configuration for the various wired network ports
on the device. As a result, wired networking broken until copy-pasting in the above configuration.

Debricking

Failsafe mode

Upgrading OpenWrt

generic.sysupgrade

If you have already installed OpenWrt and like to reflash for e.g. upgrading to a new OpenWrt version you can upgrade using the mtd command line tool. It is important that you put the firmware image into the ramdisk (/tmp) before you start flashing.

LuCI Web Upgrade Process

Terminal Upgrade Process

  • Login as root via SSH on 192.168.1.1
  • Use the following commands to upgrade.

cd /tmp/
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
sysupgrade /tmp/xxx.abc

  • If sysupgrade does not support this router, use the following commands.

cd /tmp/
wget http://downloads.openwrt.org/snapshots/trunk/XXX/xxx.abc
mtd write /tmp/xxx.abc linux && reboot

Basic configuration

Basic configuration After flashing, proceed with this.
Set up your Internet connection, configure wireless, configure USB port, etc.

Specific Configuration

Buttons

hardware.button on howto use and configure the hardware button(s).

The SL-R720X devices has one button. In the original configuration it resets the router when pressed for 5 seconds and switches WPS mode when pressed for only 1 second.

BUTTON Event
1 sec WPS
5 sec reset

Interfaces

The default network configuration is:

Interface Name Description Default configuration
br-lan LAN & WiFi 192.168.1.1/24
vlan0 (eth0.1) LAN ports (1 to 4) None
vlan1 (eth0.2) WAN port DHCP
wl0 WiFi Disabled

Switch Ports (for VLANs)

Numbers 1-4 are ports 1-4 as labeled on the unit, number 0 is the Internet (WAN) on the unit, 6 is the internal connection to the router itself. vlan0 = eth0.0, vlan1 = eth0.1 and so on.

Port Switch port
0 Internet (WAN)
1 LAN 1
2 LAN 2
3 LAN 3
4 LAN 4
5 non-connected?
6 CPU (internal)

Hardware

Info

Architecture: MIPS
Vendor: Ralink
Bootloader: U-Boot
System-On-Chip: RT3052
CPU/Speed 24Kc 384 Mhz
Flash-Chip: 29LV320DBTI-70G/ST 25P64V6P
Flash size: 4096 KiB
RAM: 32 MiB
Wireless: rt2872 2.4ghz 802.11bgn
Ethernet: ?
USB: Yes 1 x 2.0
GPIO: Yes 6 free
Serial: Yes
JTAG: No

Photos

Model Number

Top: chinaroutertopside.jpg

Bottom: chinarouterbottomside.jpg

Connectors: chinarouterconnectorsid.jpg

Detacheable Antennas

chinarouterantennaside.jpg

Opening the case

Note: This will void your warranty!

  • To open the case carefully peel off the rubber feet without ripping them apart if you want to reattach them later. There is one screw beneath each of these feet. Unscrew them and you will be able to take off the top and bottom to access the PCB.

Main PCB top:

chinarouterpcbtop.jpg

Main PCB bottom:

chinarouterpcbbottom.jpg

  • To remove the cover just unscrew the four corner phillips screws under the rubber feet.

PCB Top

PCB bottom

Serial port

The serial port is on the unpopulated header labelled "console"/"J2". Pins are, from the pin closest to J2 Gnd, Rx, Tx, Vcc. Use a 5V ↔ 3.3V level shifter. Some of the boards are shipped with a populated header. Use 57600 8N1, hard & soft flow control OFF.

Photo of PCB with markings

JTAG

port.jtag general information about the JTAG port, JTAG cable, etc.

How to connect to the JTAG Port of this specific device:

Photo of PCB with markings

Bootloader Mods

  1. you could read about bootloader in general

Hardware mods

  1. as a beginner, you really should inform yourself about soldering in general and then obtain some practical experience!

128MiB RAM Mod

I²C GPIO Mod

I²C Tiny-USB Mod

References

Back to top

toh/widemac/sl-r7205.txt · Last modified: 2014/08/14 15:32 by rspliet